arm port · Odd Fixes
Maintainers
- M Russell King <linux@armlinux.org.uk>
Paths
- F
arch/arm/ - X
arch/arm/boot/dts/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-acpi (capped at 30), ordered by date desc.
-
COLD22d
[PATCH 02/16] arm: Use sysfs_emit() for cpumask show callbacks
2026-05-28 · Yury Norov <hidden> -
COLD53d
REVIEWED: 6 (6M) [PATCH v7 3/3] ARM: omap1: enable real software node lookup of GPIOs on Nokia 770
2026-04-30 · Bartosz Golaszewski <hidden> -
COLD53d
REVIEWED: 5 (5M) [PATCH v7 2/3] ARM: omap1: use platform_device_register_full() for GPIO devices on OMAP 16xx
2026-04-30 · Bartosz Golaszewski <hidden> -
COLD53d
REVIEWED: 5 (5M) [PATCH v7 1/3] ARM: omap1: drop unused variable from omap16xx_gpio_init()
2026-04-30 · Bartosz Golaszewski <hidden> -
STALE83d
REVIEWED: 6 (6M) [PATCH v6 3/3] ARM: omap1: enable real software node lookup of GPIOs on Nokia 770
2026-04-27 · Bartosz Golaszewski <hidden> -
STALE83d
[PATCH v6 2/3] ARM: omap1: use platform_device_register_full() for GPIO devices on OMAP 16xx
2026-04-27 · Bartosz Golaszewski <hidden> -
STALE83d
[PATCH v6 1/3] ARM: omap1: drop unused variable from omap16xx_gpio_init()
2026-04-27 · Bartosz Golaszewski <hidden> -
STALE103d
REVIEWED: 6 (6M) [PATCH v5 4/4] ARM: omap1: enable real software node lookup of GPIOs on Nokia 770
2026-04-02 · Bartosz Golaszewski <hidden> -
STALE110d
REVIEWED: 6 (6M) [PATCH v4 3/3] ARM: omap1: enable real software node lookup of GPIOs on Nokia 770
2026-03-30 · Bartosz Golaszewski <hidden> -
COLD60d
REVIEWED: 41 (41M) [PATCH v2 4/6] ARM: omap1: ams-delta: convert GPIO hogs to using firmware nodes
2026-03-09 · Bartosz Golaszewski <hidden> -
STALE135d
[PATCH 4/6] ARM: omap1: ams-delta: convert GPIO hogs to using firmware nodes
2026-03-05 · Bartosz Golaszewski <hidden> -
STALE248d
[PATCH v3 1/7] syscore: Pass context data to callbacks
2025-10-29 · Thierry Reding <hidden> -
STALE282d
[PATCH RESEND 61/62] init: rename CONFIG_RD_LZ4 to CONFIG_INITRAMFS_DECOMPRESS_LZ4
2025-09-14 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 60/62] init: rename CONFIG_RD_LZO to CONFIG_INITRAMFS_DECOMPRESS_LZO
2025-09-14 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 59/62] init: rename CONFIG_RD_XZ to CONFIG_INITRAMFS_DECOMPRESS_XZ
2025-09-14 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 58/62] init: rename CONFIG_RD_LZMA to CONFIG_INITRAMFS_DECOMPRESS_LZMA
2025-09-14 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 57/62] init: rename CONFIG_RD_BZIP2 to CONFIG_INITRAMFS_DECOMPRESS_BZIP2
2025-09-14 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 56/62] init: rename CONFIG_RD_GZIP to CONFIG_INITRAMFS_DECOMPRESS_GZIP
2025-09-14 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 54/62] init: arm, x86: deal with some references to initrd
2025-09-14 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 41/62] init: rename reserve_initrd_mem to reserve_initramfs_mem
2025-09-14 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 40/62] init: rename free_initrd_mem to free_initramfs_mem
2025-09-14 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 25/62] init: rename phys_initrd_{start,size} to phys_external_initramfs_{start,size}
2025-09-13 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 21/62] init: remove all mentions of root=/dev/ram*
2025-09-13 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 19/62] init: remove mentions of "ramdisk=" command line parameter
2025-09-13 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 16/62] brd: remove "ramdisk_size" command line parameter
2025-09-13 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 11/62] init, efi: remove "noinitrd" command line parameter
2025-09-13 · Askar Safin <hidden> -
STALE282d
[PATCH RESEND 08/62] arm: init: remove FLAG_RDLOAD and FLAG_RDPROMPT
2025-09-13 · Askar Safin <hidden>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
COLD53d
REVIEWED: 5 (5M) [PATCH v7 1/3] ARM: omap1: drop unused variable from omap16xx_gpio_init()
2026-04-30 · Bartosz Golaszewski <hidden> · 1 Reviewed-by -
COLD53d
REVIEWED: 5 (5M) [PATCH v7 2/3] ARM: omap1: use platform_device_register_full() for GPIO devices on OMAP 16xx
2026-04-30 · Bartosz Golaszewski <hidden> · 1 Reviewed-by
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
COLD22d
[PATCH 02/16] arm: Use sysfs_emit() for cpumask show callbacks
2026-05-28 · Yury Norov <hidden>